Skip to content
JS
Packages

JavaScript packages

42,510 npm packages in 67 categories, with weekly downloads, 12-month growth, bundle size, last release, module format and types for each.

42,510 packages67 categoriesComparisons

All packages

42,510 packages
PackageWeekly downloads12-month changeGzipLast releaseModuleTypesCategories
@thi.ng/api
Common, generic types, interfaces & mixins
266.2k--1 month ago
8.12.28
ESM onlyBundledTypeScript tooling
@lingui/swc-plugin
A SWC Plugin for LinguiJS
266.2k--1 month ago
6.7.0
ESM onlyBundledInternationalisation
lodash.uniqueid
The lodash method `_.uniqueId` exported as a module.
266.1k+11%--
4.0.1
-NoneUtility libraries
express-http-context
Get and set request-scoped context anywhere
266k+31%-1 year ago
2.0.1
CommonJSBundledHTTP servers and web frameworks
expo-intent-launcher
Provides a way to launch Android intents, e.g. opening a specific activity.
265.9k+325%--
57.0.1
CommonJSBundledReact, HTTP servers and web frameworks
quoted-printable
A robust & character encoding–agnostic JavaScript implementation of the `Quoted-Printable` content transfer encoding as defined by RFC 2045.
265.9k+24%-9 years ago
1.0.1
CommonJSNone-
free-email-domains
Comprehensive list of free email provider domains for signup validation and disposable filtering.
265.8k+254%-10 days ago
1.12.8
CommonJSNoneEmail, Forms
tree-sitter-c
C grammar for tree-sitter
265.6k+1674%-1 year ago
0.24.1
CommonJSBundledParsers and serialisers
npm-registry-client
Client for the npm registry
265.5k+2%--
8.6.0
CommonJSNone-
caller
@substack's caller.js as a module
265.5k+47%-4 years ago
1.1.0
CommonJSNone-
rfc6902
Complete implementation of RFC6902 (patch and diff)
265.4k+110%-2 months ago
5.3.0
-Bundled-
react-otp-input
A fully customizable, one-time password input component for the web built with React
265.4k+36%--
3.1.1
ESM + CommonJSBundled-
ae-cvss-calculator
A CVSS vector modeling and score calculation implementation for all CVSS versions by {metæffekt}.
265.4k+158%-3 months ago
1.0.13
CommonJSBundledSecurity
@ckeditor/ckeditor5-react
Official React component for CKEditor 5 – the best browser-based rich text editor.
265.3k--3 months ago
11.2.0
ESM + CommonJSBundledRich text and code editors, React
gradient-parser
Parse CSS3 gradient definitions and return an AST.
265.1k+101%-7 months ago
1.2.0
ESM + CommonJSBundledParsers and serialisers
ci-env
Environment variables exposed by CI tools
265.1k+29%--
1.17.0
CommonJSNoneConfiguration, Node.js utilities
@fontsource/geist-mono
Self-host the Geist Mono font in a neatly bundled NPM package.
265k--2 months ago
5.3.0
CommonJSBundledCSS-in-JS and styling
@mapbox/parse-mapbox-token
Parse a Mapbox API token, in Node or the browser
264.9k--8 years ago
0.2.0
CommonJSNoneMaps and geolocation
cmake-ts
cmake-js rewrite in typescript to support advanced build configurations
264.9k+1486%-1 year ago
1.0.2
ESM + CommonJSBundledBuild tools, Node.js utilities
json-merge-patch
Implementation of JSON Merge Patch (RFC 7396)
264.8k+44%--
1.0.2
CommonJSNone-
totp-generator
Generate TOTP tokens from key
264.7k+14%-8 months ago
2.0.1
ESM + CommonJSBundledAuthentication and authorisation
@oxlint/binding-linux-riscv64-musl
Linter for the JavaScript Oxidation Compiler
264.7k--12 days ago
1.85.0
CommonJSNoneLinting and formatting, TypeScript tooling
react-style-proptype
validates style objects by ensuring they only have valid keys
264.6k-2%-8 years ago
3.2.2
CommonJSNoneReact
@oxlint/binding-linux-riscv64-gnu
Linter for the JavaScript Oxidation Compiler
264.6k--12 days ago
1.85.0
CommonJSNoneLinting and formatting, TypeScript tooling
es-set
An ES-spec-compliant Set shim/polyfill/replacement that works as far down as ES3
264.6k+1291%-1 year ago
2.0.1
CommonJSNonePolyfills and shims
miragejs
A client-side server to help you build, test and demo your JavaScript app
264.2k+10%-2 years ago
0.1.48
ESM + CommonJSBundledDev servers and API mocking, Testing
@fluent/syntax
AST and parser for Fluent
264.2k--3 years ago
0.19.0
ESM + CommonJSBundledInternationalisation, Parsers and serialisers
@tsoa/cli
Build swagger-compliant REST APIs using TypeScript and Node
263.8k--9 months ago
7.0.0-alpha.0
CommonJSBundledDocumentation tooling, HTTP servers and web frameworks
@univerjs/network
Network service abstractions for Univer runtime integrations.
263.6k--9 days ago
1.0.2
ESM + CommonJSBundledPDF and documents
yaml-js
Pure Javascript YAML loader and dumper, ported from PyYAML
263.6k+19%--
0.3.1
CommonJSNone-
changelog-filename-regex
A regular expression that matches a CHANGELOG filename
263.4k+32%-8 years ago
2.0.1
ESM + CommonJSNoneDocumentation tooling
@tsparticles/shape-image
tsParticles image shape
263.4k--1 month ago
4.4.0
ESM + CommonJSBundledAnimation, TypeScript tooling
gar
The lightweight Node arguments parser
263.3k+112%--
1.0.4
CommonJSNoneCLI tools and terminal utilities
@tsparticles/shape-emoji
tsParticles emoji shape
263.2k--1 month ago
4.4.0
ESM + CommonJSBundledAnimation, TypeScript tooling
@tsparticles/shape-polygon
tsParticles polygon shape
263.1k--1 month ago
4.4.0
ESM + CommonJSBundledAnimation, TypeScript tooling
ember-cli-string-utils
string utils extracted for other addons and blueprints
263.1k+30%--
1.1.0
CommonJSNone-
@napi-rs/snappy-linux-x64-musl
Fastest Snappy compression library in Node.js
263.1k--24 days ago
7.4.3
CommonJSNoneCompression and archives
color-diff
Implemets the CIEDE2000 color difference algorithm, conversion between RGB and LAB color and mapping all colors in palette X to the closest or most different color in palette Y based on the CIEDE2000 difference.
263.1k-21%--
1.4.0
ESM + CommonJSNone-
@tsparticles/shape-star
tsParticles star shape
263k--1 month ago
4.4.0
ESM + CommonJSBundledAnimation, TypeScript tooling
weaviate-client
JS/TS client for Weaviate
263k-32%--
3.14.0
ESM + CommonJSBundledTypeScript tooling
google-map-react
Isomorphic component that allows rendering react components on a google map
263k+5%-1 year ago
2.2.5
ESM + CommonJSNoneMaps and geolocation, React
chalk-animation
Colorful animations in terminal output
263k+872%-4 years ago
2.0.3
ESM onlyNoneCLI tools and terminal utilities, Animation
split-lines
Split lines into an array of lines
262.9k+118%-5 years ago
3.0.0
ESM onlyNone-
@carbon/icon-helpers
Helpers used alongside icons for digital and software products using the Carbon Design System
262.9k--10 days ago
10.83.0
ESM + CommonJSBundledReact, Icons
terra-draw
Frictionless map drawing across mapping provider
262.8k+699%-13 days ago
1.35.0
ESM + CommonJSBundledMaps and geolocation
electron-squirrel-startup
Default Squirrel.Windows event handler for your Electron apps.
262.7k+137%--
1.0.1
-None-
keyboard-key
A simple utility for determining the KeyboardEvent.key property from a keyboard event.
262.6k+21%--
1.1.0
CommonJSBundled-
best-effort-json-parser
Parse incomplete json text in best-effort manner
262.6k+261%-3 months ago
1.5.1
CommonJSBundledParsers and serialisers
zlib
Simple, synchronous deflate/inflate for buffers
262.2k-8%--
1.0.5
CommonJSNoneCompression and archives
@platejs/core
The core of Plate – a plugin system for slate
262.2k--14 days ago
53.3.14
ESM onlyBundledRich text and code editors

12-month change compares the average of the last 4 weeks of downloads with the first 4 weeks of the 52-week series. Gzip size is for the whole package, as measured by Bundlephobia. "-" means the value has not been fetched.

Categories

67 with packages