Skip to content
JS
Packages

JavaScript packages

42,510 npm packages in 67 categories, with weekly downloads, 12-month growth, bundle size, last release, module format and types for each.

42,510 packages67 categoriesComparisons

All packages

42,510 packages
PackageWeekly downloads12-month changeGzipLast releaseModuleTypesCategories
es-check
Checks the ECMAScript version of .js glob against a specified version of ECMAScript with a shell command
163.7k+98%--
9.8.1
ESM + CommonJSNoneBuild tools, Testing
@axiomhq/logging
The official logging package for Axiom
163.6k--26 days ago
0.4.1
ESM + CommonJSBundledLogging
@pdfme/pdf-lib
Create and modify PDF files with JavaScript
163.4k--19 days ago
6.1.13
ESM onlyBundledPDF and documents, TypeScript tooling
angular-mocks
AngularJS mocks for testing
163.3k-3%-4 years ago
1.8.3
CommonJSNoneTesting, Angular
@httptoolkit/util
A tiny utility package, sharing JS code widely used across HTTP Toolkit projects
163.3k--7 months ago
0.1.9
CommonJSBundledUtility libraries
xml2js-xpath
Search xml2js JSON documents with XPath query strings.
163.3k+9%-4 years ago
0.13.0
CommonJSBundled-
upng-js
Small, fast and advanced PNG / APNG encoder and decoder
163.3k+607%-8 years ago
2.1.0
CommonJSNone-
@blakeembrey/template
Fast and simple string template library
163.3k--2 years ago
1.2.0
CommonJSBundledTemplating
takumi-js
Render OG images from JSX, HTML, and CSS. No headless browser.
163.2k--20 days ago
2.14.0
ESM + CommonJSBundledCSS-in-JS and styling, React
@aws-cdk/cli-plugin-contract
Contract between the CLI and authentication plugins, for the exchange of AWS credentials
163.2k--5 months ago
2.182.2
CommonJSBundledCloud SDKs
@react-native-firebase/remote-config
React Native Firebase - React Native Firebase provides native integration with Remote Config, allowing you to change the appearance and/or functionality of your app without requiring an app update.
163.1k--30 days ago
26.4.0
CommonJSBundledCloud SDKs, React
@rnmapbox/maps
Community-supported, open-source React Native library for building maps using Mapbox native maps SDK for iOS and Android
163k--2 months ago
10.3.5
CommonJSBundledMaps and geolocation, React
roboto-fontface
A simple package providing the Roboto fontface.
163k+16%--
0.10.0
CommonJSNone-
@11ty/eleventy
A simpler static site generator.
163k--4 months ago
3.1.6
ESM + CommonJSBundledStatic site generators and meta-frameworks, Templating
elen
ELEN - Efficient Lexicographic Encoding of Numbers. For JavaScript.
162.9k+2237%-7 years ago
1.0.10
CommonJSNone-
@stdlib/complex-float32-ctor
64-bit complex number.
162.9k--7 months ago
0.1.1
CommonJSBundled-
graphology-layout
Collection of basic layout algorithms for graphology.
162.9k+601%-4 years ago
0.6.1
CommonJSBundled-
code-inspector-plugin
Click the dom on the page, it will open your IDE and position the cursor to the source code location of the dom.
162.8k+390%-23 days ago
2.0.9
ESM + CommonJSBundledVue, Bundler plugins and loaders
href-content
Get content from link tags in an HTML document.
162.8k+20%-2 years ago
2.0.3
CommonJSNoneEmail
react-focus-on
The final solution for WAI ARIA compatible modal dialogs or full-screen tasks.
162.8k-6%-9 months ago
3.10.2
ESM + CommonJSBundledAccessibility, React
@llamaindex/liteparse
Fast, lightweight PDF and document parsing with spatial text extraction
162.8k--12 days ago
2.14.7
ESM + CommonJSBundledPDF and documents
idn-hostname
An internationalized hostname validator as defined by RFC5890, RFC5891, RFC5892, RFC5893, RFC3492 and UTS#46
162.7k+159048%-20 days ago
17.0.4
CommonJSBundledSchema validation, Node.js utilities
@react-pdf-viewer/attachment
A React component to view a PDF document
162.7k--3 years ago
3.12.0
CommonJSBundledPDF and documents, React
maximatch
Extends multimatch() with support for filter functions and regular expressions
162.6k-18%--
0.1.0
-NoneFiles and file systems
@docuseal/react
DocuSeal React components to integrate documents signing process into apps. ✍️
162.6k--4 months ago
1.0.75
ESM + CommonJSBundledReact
quadbin
Utility functions for working with Quadbins
162.6k+37%-1 year ago
0.4.2
ESM + CommonJSBundled3D, WebGL and game engines, Charts and data visualisation
real-cancellable-promise
A simple cancellable promise implementation that cancels the underlying HTTP call.
162.5k+153%-1 year ago
1.2.3
ESM + CommonJSBundledReact, TypeScript tooling
@cyntler/react-doc-viewer
File viewer for React.
162.5k--1 year ago
1.17.1
ESM + CommonJSBundledReact
react-force-graph-3d
React component for 3D force directed graphs
162.5k+1095%-7 months ago
1.29.1
ESM onlyBundled3D, WebGL and game engines, React
@vue/cli-plugin-unit-jest
unit-jest plugin for vue-cli
162.4k--1 year ago
5.0.9
CommonJSNoneCLI tools and terminal utilities, Vue
@cryptography/aes
High-performance synchronous AES implementation for JavaScript
162.2k--6 years ago
0.1.1
ESM + CommonJSBundledCryptography and hashing
defs
Static scope analysis and transpilation of ES6 block scoped const and let variables, to ES3.
162.2k-21%-10 years ago
1.1.1
CommonJSNoneBuild tools, Linting and formatting
@sap/hana-client
Official SAP HANA Node.js Driver
162.2k--16 days ago
2.30.27
CommonJSBundledDatabase clients and drivers
react-dropzone-esm
Simple HTML5 drag-drop zone with React.js
162.1k+95%-1 year ago
15.2.0
ESM + CommonJSBundledReact
normalize-html-whitespace
Safely remove repeating whitespace from HTML text.
162k-14%-7 years ago
1.0.0
CommonJSNoneNode.js utilities
@fastify/aws-lambda
Inspired by aws-serverless-express to work with Fastify with inject functionality.
161.9k--2 months ago
6.4.1
CommonJSBundledCloud SDKs, Node.js utilities
isomorphic-textencoder
encode/decode Uint8Arrays to strings
161.9k+173%-7 years ago
1.0.1
CommonJSNone-
broccoli-filter
Helper base class for Broccoli plugins that map input files into output files one-to-one
161.9k-15%-8 years ago
1.3.0
CommonJSNone-
draggabilly
make that shiz draggable
161.9k+4%-4 years ago
3.0.0
CommonJSNone-
@stdlib/complex-float64-ctor
128-bit complex number.
161.9k--7 months ago
0.1.2
CommonJSBundled-
html-to-pdfmake
Convert HTML code to PDFMake
161.8k+102%--
2.5.34
CommonJSNonePDF and documents
material-design-icons-iconfont
Material Design Icons DX
161.8k-18%-4 years ago
6.7.0
CommonJSNoneIcons
whatshell
Whatshell: a Rust WhatsApp Web CLI for coding agents
161.7k--5 months ago
0.1.2
-NoneCLI tools and terminal utilities
@sap-cloud-sdk/util
SAP Cloud SDK for JavaScript general utilities
161.7k--1 month ago
4.9.1
CommonJSBundledDocumentation tooling
xhr-mock
Utility for mocking XMLHttpRequest.
161.6k+29%-6 years ago
2.5.1
CommonJSBundledDev servers and API mocking, Testing
buffer-es6
Node.js Buffer API, for the browser
161.6k+30%-9 years ago
4.9.3
ESM + CommonJSNone-
uuencode
Node.js implementation of the Unix program uuencode.
161.5k-16%--
0.0.4
-None-
@ts-rest/react-query
react-query client integration for @ts-rest
161.4k--1 year ago
3.52.1
ESM + CommonJSBundledTypeScript tooling
@invertase/react-native-apple-authentication
A complete Apple Authentication services API for React Native iOS apps.
161.4k--8 months ago
2.5.1
CommonJSBundledAuthentication and authorisation, React
prisma-kysely
Generate Kysely database types from a Prisma schema
161.4k+104%-1 month ago
3.2.1
ESM onlyNoneORMs and query builders, TypeScript tooling

12-month change compares the average of the last 4 weeks of downloads with the first 4 weeks of the 52-week series. Gzip size is for the whole package, as measured by Bundlephobia. "-" means the value has not been fetched.

Categories

67 with packages