Skip to content
JS
Packages

JavaScript packages

42,510 npm packages in 67 categories, with weekly downloads, 12-month growth, bundle size, last release, module format and types for each.

42,510 packages67 categoriesComparisons

All packages

42,510 packages
PackageWeekly downloads12-month changeGzipLast releaseModuleTypesCategories
eslint4b-prebuilt
Pre-bundled version of ESLint and its core rules that can be loaded in the browser
9.7k+151%-6 years ago
6.7.2
ESM + CommonJSNoneLinting and formatting
to-integer-x
ToInteger converts 'argument' to an integral numeric value.
9.7k-5%-7 years ago
4.2.2
ESM + CommonJSNoneDOM and browser utilities, Node.js utilities
ckeditor4-angular
Official CKEditor 4 component for Angular.
9.7k-19%-1 year ago
5.2.1
ESM + CommonJSBundledRich text and code editors, Angular
@quasar/quasar-ui-qcalendar
QCalendar - Day/Month/Week Calendars, Popups, Date Pickers, Schedules, Agendas, Planners and Tasks for your Vue Apps
9.7k--1 month ago
5.3.0
ESM onlyBundledQueues and background jobs
next-optimized-images
Automatically optimize images used in next.js projects (jpeg, png, gif, svg).
9.7k-40%-6 years ago
2.6.2
CommonJSNoneImage processing, React
@docmd/plugin-installer
Installer utility to add and remove plugins for docmd.
9.7k--18 days ago
0.9.6
ESM onlyBundledMarkdown, Parsers and serialisers
@material-symbols/svg-300
Latest optimized SVGs with weight 300 for Material Symbols.
9.7k--17 days ago
0.47.5
-NoneIcons
bookshelf-uuid
Automatically generates UUID for your models
9.7k+1552%-7 years ago
1.0.1
CommonJSNoneCryptography and hashing
react-google-calendar-api
An api to manage your google calendar
9.7k+266%-3 years ago
2.3.0
CommonJSBundledReact, TypeScript tooling
@mintplex-labs/piper-tts-web
Fork of @diffusion-studio/vits-web for easier built-in PiperTTS use.
9.7k--1 month ago
1.0.5
ESM onlyBundledVideo and audio
@pnpm/crypto.integrity
Parse and validate integrity strings
9.7k--1 month ago
1100.0.6
ESM onlyBundledCryptography and hashing
@electric-sql/pglite-react
Hooks for using PGlite
9.7k--1 month ago
0.4.8
ESM + CommonJSBundledDatabase clients and drivers, React
@gravity-ui/prettier-config
Gravity UI Prettier config, following our styleguide
9.7k--6 months ago
1.1.1
-BundledLinting and formatting
nice-cache
A node.js in-memory cache - get, set, or subscribe to the auto-updater loop
9.7k+153%-11 years ago
0.0.5
CommonJSNoneCaching
parse-email-address
Parse/validate email addresses with RFC-5321, and message header address lists with RFC-5322.
9.7k+2127%-1 month ago
0.0.5
ESM onlyBundledEmail
@commercetools/sdk-auth
Auth module for different authentication flows of commercetools platform API
9.7k--1 year ago
5.0.1
ESM + CommonJSNoneAuthentication and authorisation
babili-webpack-plugin
Babili Plugin for Webpack
9.7k+124%-9 years ago
0.1.2
CommonJSNoneBundler plugins and loaders
inquirer-date-prompt
A date prompt plugin for Inquirer.js.
9.7k+75%-3 years ago
3.0.0
ESM onlyBundledCLI tools and terminal utilities
proxying-agent
Node HTTP/HTTPS Forward Proxy Agent
9.7k-25%-7 years ago
2.4.0
CommonJSNone-
redux-persist-expo-filesystem
Redux-Persist storage engine using Expo filesystem that removes the need to eject Expo/CRNA app
9.7k+80%-5 months ago
3.0.0
CommonJSBundledReact
openapi-data-validator
Automatically validate API requests and responses with OpenAPI 3.
9.7k+196%-11 months ago
2.0.54
CommonJSBundledDocumentation tooling, HTTP servers and web frameworks
orejime
A lightweight and accessible consent manager
9.7k+29%-2 months ago
3.2.1
-NoneAccessibility
@liaoliaots/nestjs-redis-health
Redis(ioredis) health checks module for Nest framework (node.js).
9.7k--3 years ago
9.0.4
CommonJSBundledDatabase clients and drivers, Node.js utilities
rudy-match-path
link to URL path matching borrowed from React Router
9.7k-37%--
0.3.0
CommonJSNoneRouting
@teispace/next-themes
Feature-rich, lightweight theme management for Next.js and React. Zero-flash SSR, hybrid storage, view transitions, typed themes.
9.7k--1 month ago
3.0.2
ESM onlyBundledReact, TypeScript tooling
calligraph
Fluid text transitions powered by Motion
9.7k--6 months ago
1.4.1
ESM onlyBundledAnimation
gmap-vue
This is a google map component for Vue.js, updated for Vue 2 compatibility
9.7k-4%--
3.5.4
ESM + CommonJSNoneVue
components
Upstage component library.
9.7k-60%--
0.1.0
CommonJSNoneUI component libraries
rollup-plugin-multi-entry
Allows specifying multiple entry points with rollup.
9.7k+26%--
2.1.0
CommonJSNoneBundler plugins and loaders
step-function-worker
Easy AWS step function activity worker in node.js
9.7k-20%-4 years ago
3.0.0
CommonJSNoneCloud SDKs
windows-system-proxy
Access the Windows system proxy settings from Node.js
9.7k+444%-1 year ago
1.0.1
CommonJSNone-
address-rfc2822
RFC 2822 & 5322 (Header) email address parser
9.7k-31%-4 months ago
2.2.4
CommonJSNoneEmail, Parsers and serialisers
mongo-escape
Escape variables to prevent NoSQL injection in MongoDB
9.7k+250%-9 years ago
2.0.6
CommonJSNoneSecurity, Database clients and drivers
react-facebook-auth
A Component React for Facebook authentication
9.7k+13%-8 years ago
1.4.0
ESM + CommonJSNoneReact, Authentication and authorisation
visionscarto-world-atlas
Derived from mbostock's world-atlas: Pre-built TopoJSON from Natural Earth.
9.7k+1127%--
1.0.0
-NoneMaps and geolocation
to-string-x
ES6-compliant shim for ToString.
9.7k+6%-7 years ago
2.1.1
ESM + CommonJSNoneDOM and browser utilities, Node.js utilities
vitest-mock-commonjs
Module loader shims 'require' to allow mocking code-under-test CommonJS modules from vitest
9.7k+884%-2 years ago
1.0.2
ESM onlyBundledTesting
candygraph
Fast by default, flexible 2D plotting library.
9.7k+61%-3 years ago
0.10.0
ESM + CommonJSBundledCharts and data visualisation
sema4
Promise based Semaphores
9.7k+2773%-2 years ago
0.1.3
ESM + CommonJSBundledPromises and async control flow
overmind
Frictionless state management
9.7k+15%-10 months ago
28.2.1
ESM + CommonJSBundledState management
@rematch/immer
Redux-Immer v6 plugin for Rematch. Provides immutable ability for rematch.
9.7k--4 years ago
2.1.3
ESM + CommonJSBundledState management
deep-freeze-es6
deep freeze, works with Map and Set
9.7k+44%-1 year ago
5.0.0
ESM onlyBundled-
handlebars-jest
Handlebars transformer for Jest
9.7k-6%-4 years ago
1.0.0
CommonJSNoneTemplating, Testing
@cfworker/uuid
Serialize/deserialize V4 UUIDs from a Uint8Array
9.7k--1 year ago
4.0.4
ESM + CommonJSBundledCloud SDKs, Cryptography and hashing
@logtape/lint
Lint rules for LogTape usage patterns (ESLint, Oxlint, Deno Lint)
9.7k--17 days ago
2.3.7
ESM + CommonJSBundledLinting and formatting, Logging
@markmend/core
Streaming Markdown syntax completion.
9.7k--15 days ago
2.0.0
ESM onlyBundledMarkdown, Parsers and serialisers
alova
The request strategy layer for JavaScript. 20+ ready-made strategies cut your request code by up to 70% — pagination, forms, uploads, retry, rate-limit and more. One API spans React, Vue, Svelte, Solid, mini-programs and the server.
9.6k+80%-1 month ago
3.5.5
ESM + CommonJSBundledQueues and background jobs, React
kysely-plugin-serialize
Auto serialize / deserialize plugin for kysely
9.6k+420%-1 year ago
0.8.2
ESM + CommonJSBundled-
ol-contextmenu
Custom Context Menu for Openlayers
9.6k+23%-3 months ago
6.0.1
ESM + CommonJSBundledMaps and geolocation
types-tsconfig
Type checking for tsconfig.json
9.6k+840%-2 years ago
2.1.1
ESM onlyBundledTypeScript tooling

12-month change compares the average of the last 4 weeks of downloads with the first 4 weeks of the 52-week series. Gzip size is for the whole package, as measured by Bundlephobia. "-" means the value has not been fetched.

Categories

67 with packages